首页 > webfront > style > sass > > 正文

gem安装compass出错……Operation not permitted

发布人:zhoulujun@live.cn    点击:

gem安装compass出错……Operation not permittedsudo 继续安装,切换到root继续安装,还是不行……这是因为苹果收紧了安全政策,不能在

gem安装compass出错……Operation not permitted

sudo 继续安装,切换到root继续安装,还是不行……

这是因为苹果收紧了安全政策,不能在 /usr/local 之外的文件夹下写入文件。

可以这样做:

sudo gem install -n /usr/local/bin compass

Screen Shot 2016-06-28 at 14.21.56.png

udo mkdir compass

mkdir: compass: Operation not permitted

mianguan:bin root# sudo gem install compass

ERROR:  While executing gem ... (Errno::EPERM)

    Operation not permitted - /usr/bin/compass

mianguan:bin root# sudo gem install -n /usr/local/bin compass

    Compass is charityware. If you love it, please donate on our behalf at http://umdf.org/compass Thanks!

Successfully installed compass-1.0.3

Parsing documentation for compass-1.0.3

Installing ri documentation for compass-1.0.3

1 gem installed